The Fluffshack

Unraveling the world one sock at a time

A fist full of broken hardware

The last 4 days have been nightmarish. As in, the worst kind of hardware upgrade nightmare.

IMG_3187 by you.

It started early last week, when I started getting serious issues playing Mass effect. The graphics driver would suddenly crash and reset, causing an interruption and minimizing the game. Windows would restart the driver, generate a popup, and then I could keep playing.
This started to get progressively worse, as after the first crash, the in-game graphics would slowly start to corrupt. Textures would start to go missing, geometric shapes would start to get out of sync, and lighting effects would go haywire. Tried the newest Nvidia drivers, no effect.

IMG_3195 by you.
The 8800 even failed in dos mode.

IMG_3196 by you.
My old card, the 8800GTX
Now I was already considering getting a better card, as I was not impressed by the performance of Mass Effect, and my Nvidia 8800GTX was getting on a bit, now over 2 years old.
So I went out and got myself the new Nvidia 295, which is basicly a duel-core version of a 260.
Its the most powerful card on the market today.
I also saw that the quad-core Intel 775’s where down to some nice prices, so I also pickup up the 3Ghz version, the q9650. I knew my mainboard, the Asus Striker Extreme, should be able to use it.

IMG_3186 by you.

On Thursday I swapped out the Nvidia cards, and had a good night of play on the new 295. But it was obvious how much of a bottleneck the CPU was now.
The next night, I swapped out the CPU. However, imagine my suprise when the Quad core didnt play nice at all. The PC would not boot at all with it in there. Under the assumption it was lack of having the correct microcode for the new CPU, I downloaded the last BIOS file, and flashed it with the EZ-Flash tool in the Bios.
That was the last time my Striker Extreme ever booted.
I am clueless about what went wrong. It was the correct Bios file, and a perfectly normal and supported means of flashing.

So Saterday I went back to the shop, and got myself an Asus P5Q Deluxe mainboard.
After putting it all back together again, I let the original Vista installation boot up.
It actually dealt with all the changes quite well.
Tried mass effect, and while it ran very smoothly now, as expected, within minutes I got pretty bad texture and vexel corruption. So not exactly the same problem as with the old card, but quite similar.
Supreme Commander ran smoothly and without any corruption, but would suddenly crash out without warning.
I ran into an additional problem with Vista. Because i had changed so many bits of hardware, it now said i needed to re-activate it. But when I tried this, it said the key was already in use. Rather strange, considering this was a volume-license key and already in use by my laptop and several other computers i am aware of. Volume license keys should be able to be used multiple times.

IMG_3164 by you.
New card: the Nvidia 295GTX duel core

IMG_3188 by you.New board: The Asus P5Q Deluxe

By this point, I was suspecting the driver-instability, if that is indeed what it was, may well be down to windows. Coupled with the activation issue, I decided to take the opertunity and install Windows 7, RC build 1700. Once this was installed, I went about getting the games back on. Mass effect needed to be re-downloaded, so I gave GTAIV a try. This was on the default drivers supplied with Windows 7.
Much to my disappointment, I got severe texture and shading corruption again, similair to what i had in Mass effect.

IMG_3193 by you.

I have tried various combination’s of drivers now, but the largest difference has been when I have turned off multi-core rendering in the Nvidia control panel. The problems are there clearly with just 1 core, but with 2 cores on GTA crashes almost immediately. I tried some Left 4 Dead, which crashed on 2 cores, but ran reasonably well on 1 core. Most distressingly, is that sometimes when it crashes, for example in Supreme Commander, it shows a bad-pixel pattern over the screen, not just in 3D, but also on the 2D Windows desktop.

IMG_3191 by you.


Supreme Commander with pixel snow inside the game, and even on Windows desktop

Mass effect goes crazy with duel cores on, vexel nightmare. With just a single core on for rendering, it only(!) freezes every 5 minutes.
So I am more or less out of ideas. My suspicion is that my new card is as broken as my old card. And the old card is very broken, as even in the boot screen it showed vertical red lines across the screen, probably indicating fried memory or something else bad.
We already threw out the original box of the 295, but its got a 3 year warranty, so I should be able to get it repaired, or get a replacement. I am hoping for the latter.

Maybe I will think of something else to try tomorrow, but it looks like i will be going back to the shop soon.

June 14th, 2009 Posted by | Angry, Gadgets, Tech | 2 comments